1

I'm trying to bulk import Task records using the Bulk API 2.0, which works perfectly fine in the sandbox, but fails with this error every time when I try to create the job in production:

[{"errorCode":"INVALIDJOB","message":"InvalidJob : Unable to find object: Task"}]

Then I tried following the documentation example exactly by using Contact as the object, but I just get the same error:

[{"errorCode":"INVALIDJOB","message":"InvalidJob : Unable to find object: Contact"}]

I double checked that the app has full access to the API, so it doesn't seem to be a permissions issue.

4
  • can you provide a body of call.
    – Ayub
    Commented Jan 3, 2019 at 5:41
  • 2
    The app might have full access to the api... but does the user have access to the objects? Commented Jan 3, 2019 at 6:02
  • @SebastianKessel That's a great question, I'm new to Salesforce and am not entirely familiar with the permissions system. I'll check tomorrow.
    – Ben Baron
    Commented Jan 3, 2019 at 6:52
  • 1
    @SebastianKessel Tested with a different Salesforce account and it works perfectly. Looks like you were correct that it was a permissions issue. Would you like to repost your comment as an answer so I can accept it?
    – Ben Baron
    Commented Jan 4, 2019 at 20:05

1 Answer 1

1

Ben, this sounds as if the user in question does not have access to the objects. I recommend you either adjust the user's profile or try with a new user.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .