1

After push we have sfdx force:source:pushenter image description here but not able to see helloWorld component on Salesforce enter image description here custom tab is empty.

  • Why your code is in aura folder? It should be in lwc folder – Pranay Jaiswal Dec 31 '18 at 9:56
  • lwc folder also has a code. but if I remove a component from aura then having an issue while pushing. D:\salesforce component new start\mywork>sfdx force:source:push === Pushed Source No results found – Vaishali Garg Dec 31 '18 at 10:00
  • Have you added target in xml file? – Tushar Sharma Dec 31 '18 at 12:19
  • @codeyinthecloud This is not a LWC question, it's a mistagged lightning-aura-components question. You can tell because it's (a) in the aura folder, (b) has no errors on push, and (c) has the Aura format of code (LWC uses different metadata files and such). – sfdcfox Jan 1 at 4:14
  • @sfdcfox my bad I haven’t looked close enough. – codeyinthecloud Jan 1 at 4:15
0

Today to develop Lightning Web Components, you need to use the pre-release version of the Salesforce CLI. Try running the following: install salesforcedx@pre-release

I don’t think you have the pre-release version installed, as lwc aren’t found and pushed when you run force:source:push.

To be sure which version of the CLI you’re using, just run sfdx plugins --core

  • These all... @salesforce/plugin-generator 1.0.1 (core) @salesforce/sfdx-trust 1.0.8 (core) builtins 1.0.0 (core) salesforcedx 45.0.12 (pre-release) – Vaishali Garg Dec 31 '18 at 11:38
  • it's found push but nothing return. something just like this. after i use this command "sfdx force:source:push" i am getting the result this, === Pushed Source No results found i am following these steps trailhead.salesforce.com/content/learn/projects/… – Vaishali Garg Dec 31 '18 at 11:40
  • Can you try under your project folder to go to .sfdx/orgs, delete everything in there and try again ? – Fabien Taillon Dec 31 '18 at 13:34
  • This is not a LWC question. – sfdcfox Jan 1 at 4:07
  • In one of the comments, Vaishali said there is also code in the lwc folder, so I thought that only the aura bundle is pushed. I had the issue after an sfdx update that removed my pre-release version of the CLI, lwc was there but never pushed to the server. Still not sure about the question though. – Fabien Taillon Jan 1 at 17:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.