0

I am new to Salesforce technology and I have practiced basic lightning course in Salesforce developer console. I am trying to implement same in Eclipse IDE with force.com plugin. I have imported all projects from my salesforce account into eclipse IDE by providing all the salesforce credentials, but when I tried to preview my app by clicking Force.com --> Show in Salesforce Web it is taking me to the web page which is URL No Longer Exists. I am able to see my web page when I click preview in Developer Console but in Eclipse I'm unable to do.

NOTE: The URL when I run from developer console is different from the URL when I click Show in Salesforce Web from ECLIPSE.

What are the settings I need to update or how to change URL so that when I click run button in Eclipse I can view my lightning web page in the browser?

Note: I have given all the details in project properties and all my changes are being reflected to a salesforce server as well. This is my project properties in force.com ide

This is actual output from developer console

This is web page coming from force.com ide eclipse

3

The option "Show in Salesforce Web" is not intended to take you to a preview of your Lightning application. It's trying to take you to the metadata definition of the component you selected - if you had selected an Apex class, you would be taken to the view in Salesforce Setup of that Apex class. Note the 0Ad Id in your URL bar - that's the key prefix for AuraDefinition.

I don't know why Eclipse fails to show you the metadata definition, but you shouldn't anticipate it being fixed. The Force.com IDE is now in maintenance-only mode and will receive only critical security fixes until being end-of-lifed next year.

You should consider, since you are starting new, using Visual Studio Code with the Salesforce DX extension pack instead. For quick previewing of Aura applications, the Developer Console is the best way I know.

  • Thank you for the quick response. I would definitely follow your advice. – Pran Dec 20 '18 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.