1

I am getting this error when running my sfdx plugin in jenkins not sure what it is asking me to do, I have the latest sfdx cli installed?

ERROR running AuthLogin: The service and account specified in key.json do not match the version of the toolbelt.

Try this:

Check your toolbelt version and re-auth.

0

I've just faced the same problem and this approach solved my issue: Delete the key.json file (on Linux it is in $HOME/.sfdx folder) and try to log again. More about this issue at here: https://github.com/forcedotcom/sfdx-core/issues/83

| improve this answer | |
  • Hi i can't seem to find the key.json in $HOME/.sfdx folder, is it only available after first login? – lodoss118 Jan 4 '19 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.