3

After creating Data Extension I cannot change External Key. Each time I change it and click "Done", refresh page and it's still the same key.

7
  • If you are sure about not re-using the same external key that you use on another data extension, you might create a support case: help.salesforce.com/… Dec 19, 2018 at 15:06
  • I tried with unique.
    – Vlad Shpak
    Dec 19, 2018 at 15:10
  • Are you doing this in Email Studio or in Contact Builder? I have experienced issues when trying to change key in Contact Builder, but succeeded doing it for same DE in Email Studio Dec 20, 2018 at 7:53
  • @LukasLunow Contact Builder
    – Vlad Shpak
    Dec 20, 2018 at 7:54
  • 1
    Try in Email Studio, and see if this solves it Dec 20, 2018 at 7:55

1 Answer 1

6

I have seen same "behaviour" in Contact Builder myself. Changing External Key for same Data Extension in Email Studio usually works.

Edit September '23: I think this one is downprioritized (which it shouldn't be), as there is the above workaround. Please vote on this known issue to raise awareness with Salesforce.

2
  • 1
    And to the day three years later: this is still how it has to be done. Dec 20, 2021 at 13:43
  • 1
    Just chiming in, 2 years later, this is still how it is done.
    – Peter Luo
    Sep 19, 2023 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .