-1

I am getting below error while editing visual force pages in Eclipse(Neon) - Force.com IDE (eclipse45).

org.eclipse.ui.ide.FileStoreEditorInput cannot be cast to org.eclipse.ui.IFileEditorInput

  • This appears to be an internal Eclipse error, so the first suggestion is probably to reinstall Eclipse and the Force.com IDE. Note that Salesforce has officially announced the end of life for the Force.com IDE - it's a good time to start evaluating alternatives. – David Reed Dec 19 '18 at 11:56
  • Thanks For your response David. I have already tried uninstall and reinstall Eclipse and Force.com IDE but it couldn't solve this issue. Yes i am aware of end of life for Force.com IDE, i am working on alternatives (VS code + Salesforce extension pack) . – Pramod Singh Dec 19 '18 at 12:20
0

I have found the solution, this issue is happening because there was no active connection with salesforce org. Tried to reconnect with salesforce org and its resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.