1

I have installed the Salesforce CLI version 6.44 in my new Mac. The installation runs smoothly with no errors. Then I run the command 'sfdx --help' in the terminal window. It gives neither any error nor any output.

Have probably missed something?

6
  • don't think that's a valid command, try sfdx --version Dec 18 '18 at 4:06
  • I agree. That is not a valid command. It's same when I run 'sfdx --version', nothing happens. Is there a way to see something is going wrong?
    – Shiran
    Dec 18 '18 at 4:14
  • this link should help - developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/… Dec 18 '18 at 4:18
  • If you go in to a terminal, what's the output of which sfdx?
    – sfdcfox
    Dec 18 '18 at 4:22
  • it gives me /usr/local/bin/sfdx
    – Shiran
    Dec 18 '18 at 4:36
1

You should be able to get some logs by looking into USER_HOME_DIR/.sfdx/sfdx.log .

If you are on macOS then simply cd into the home directory using cd $HOME and then cd again to the .sfdx folder .

You will find sfdx.log file if you open the .sfdx folder .This should have more info for you .

If you are behind the firewall , then update your environment variables as per the below instructions

https://developer.salesforce.com/docs/atlas.en-us.sfdx_setup.meta/sfdx_setup/sfdx_setup_install_cli_firewall.htm

2
  • 1
    Somehow this started working now. I believe it is related to some setup done by Infra guys when provisioning my new MacBook. I have to setup the HTTP_PROXY to use SFDX CLI behind corporate firewall.
    – Shiran
    Dec 18 '18 at 22:11
  • @wawass Added some more info so that helps others as well Dec 18 '18 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.