2

I had following situation. When I tried to edit and save some of custom object CustomObject1__c instance, I received error in the top of the page

Error: Invalid Data. 
Review all error messages below to correct your data.
Operation not valid for this user type

When I investigated deeper, so I have found out that this object CustomObject1_c has lookup relation to another object CustomObject2_c for which instance of one more custom object CustomObject3_c have been trying to be inserted. Object CustomObject3_c also has lookup relation to object CustomObject2_c, so during insert object CustomObject2_c was considered to be updated with new child relationship record.

So when I tried manually to update corresponding instance of CustomObject2__c object, I saw another error instead of page

Can't Perform this Operation
You can't perform this operation with the selected user type. 

Click here to return to the previous page.

I was trying to perform this operation under system administrator, so I supposed I had all the permissions to perform any of operations on any object.

Why did I have that error?

2 Answers 2

3

You are not allowed to set the OwnerId of an object to an Inactive User or a User with a Chatter Free license. There are a few exceptions for Chatter Free license but such as Files, etc but Custom Objects are not allowed.

1

So I want to share the answer I have found.

CustomObject2__c has a trigger which tried to modify OwnerId of instance of that object to AssignedUser field value.

I have found out that AssignedUser value for the failing object was inactive user, and it seems inactive user can't own custom object records.

3
  • Correct; new records cannot be assigned to inactive users.
    – Mike Chale
    Commented Jan 16, 2014 at 17:20
  • How about after turning on 'Enable "Set Audit Fields upon Record Creation" and "Update Records with Inactive Owners" User Permissions' option under Quick Find -> User Interface? Commented Dec 14, 2018 at 15:11
  • Is this some new user permission? On the time of this post there were no such user permissions
    – Patlatus
    Commented Dec 16, 2018 at 18:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .