11

I have performed below steps-

  • Install CLI
  • Install extensions "Salesforce Extension Pack" and "Saleforce CLI Itegration"

I am getting only few SFDX command options in Command Palette. Also i have tried uninstall VS Code multiple times but issue still persists.

Please suggest if i am missing some steps here.

enter image description here

8

Oh, I know the answer. You have to create a project first. Then and only then the other commands will become available for you


Well, yeah. That's the answer. But just to make it cleaner for you. All the commands, that exists in the palette works with scratch orgs, which can't be used outside a project, because of project-scratch-org.json file, that defines the shape of your scratches

| improve this answer | |
  • 1
    Thanks for your response, i have cloned project from GIT repository, still i don't see Auth command available under command palette. Do i need to create the scratch project first to get the command available? – Pramod Singh Dec 14 '18 at 6:56
  • Well.. in case, if everything is set properly, you do not. May I ask you to list all the elements lay inside the folder? – being of habits Dec 14 '18 at 7:01
  • Its a test project created under GIT repository first... Not in same format as Eclipse or VS code project. I am trying to sync the sandbox code with GIT repository later on it will be used for deployment through Jenkins. – Pramod Singh Dec 14 '18 at 7:06
  • To be pedantic, it's the sfdx-project.json file that needs to exist. – sfdcfox Dec 14 '18 at 7:22
  • Oke, I got it. So, here's the flow: 1) create a sfdx project; 2) clone the repo inside it – being of habits Dec 14 '18 at 7:22
2

I was having this same issue after I created a project and tried to open vscode and log in. The solution I found was going to file -> open folder -> choose the project folder created originally. The options to login option will be available in the command palette.

It was confusing since in the explorer panel the file directory was showing the project files.

| improve this answer | |
0

I had this issue even though I had a project open with a sfdx-project.json in the root. What ended up being the problem is that my folder path had a space at the end (don't ask me why, not sure):

"C:\path\to\folder \" <-- Notice the space at the end

So my two suggestions:

  1. Check your project's file path
  2. Use the developer console in VSCode (go to Help -> Toggle Developer Tools -> Go to Console Tab) to help debug
| improve this answer | |
0

sometimes you will need to upgrade the Sforce extn pack or the sf CLI to the latest version. just uninstall the extensions and install again. also you need to create project manifest.

| improve this answer | |
0

If tried the above and still not working:

  1. Create again a project with manifest in VSCode with the option Ctrl+P
  2. Once it is created, pay attention to a warning that VS Code throws in the right down corner of your screen saying "Would you like to install extensions in this project?". Hit YES.

After trying all the above, I found out that this was the problem. Somehow VS Code is not deploying the SFDX extension to the project from the very beginning.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.