0

https://developer.salesforce.com/docs/atlas.en-us.mc-apis.meta/mc-apis/messageDefinitionSends.htm][1]

I followed the instructions and got success response but I didn't receive email. Then I used the id to get Email Status and got 404 error.

Here is my json :

POST : https://www.exacttargetapis.com/messaging/v1/messageDefinitionSends/key:40055/send

{
    "To": {
        "Address": "example@gmail.com",
        "SubscriberKey": "example@gmail.com.tw"
    },
    "Options": {
        "RequestType": "ASYNC"
    }
}

GET : https://www.exacttargetapis.com/messaging/v1/messageDefinitionSend/key:40055/deliveryRecords/{id}

Please let me know how I can resolve the issue.

5
  • Is your Triggered Send running, or paused? Dec 12 '18 at 13:28
  • I am not positive if it applies here like it does on other calls (e.g. Data Events) where SFMC is required to 'switch on' the ability for you to make async calls. I would verify this as well as the status of your TSD as @LukasLunow mentioned. Dec 12 '18 at 14:22
  • 1
    ASYNC route for Triggered Sends does not require same enablement as ASYNC DE upserts. So Bensen Liu should be fine here, @Gortonington Dec 12 '18 at 14:31
  • Thanks @LukasLunow. I wasn't sure if that was the case or not. Dec 12 '18 at 14:41
  • @Lukas Lunow,Thank you very much!! I only published it but didn't start it. It's working now.
    – Bensen Liu
    Dec 12 '18 at 14:54
1

Make sure your Triggered Sends are both published and started. Also remember to pause, publish and start the TS each time you edit the email content, as changes otherwise will not be reflected in the sent email.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.