In my orgs, for some truly obscure reasons, a Product has been archived.

I've bookmarked it, and I can now see it with the direct url ( MYORGSURL/objectId ), but I can't do anything with it: I can't "restore", neither delete it. On top, I can see that is an 'Archived Product' object type.

The message << This record has been archived and is no longer available for any operation >> is where the "Edit" and "Restore" buttons should be.

Unfortunately, I can't even delete it using Dataloader, neither from Apex: I get the message "the row is already deleted".

The issue is that "something" in my orgs is still detecting the object, and I can't insert again it because the product code is already existing (and should be unique), thus making fail any insert operation.

My only option would be to delete it, but is...already deleted. I'm a system administrator in my org, so I have right to do basically anything, but it seem that I can't do anything on that record.

How I can proceed?

  • is this a fullcopy or partial copy sandbox? I faced similar issue in these sandboxes – Pranay Jaiswal Dec 6 at 15:14
  • Have you tried to contact Salesforce Support about this? That does seems like a platform issue to me – kurunve Dec 6 at 15:14

This is known behaviour. I tried replicating your issue.

A) The created product, Assigned to an Opportunity then tried deleting it. It gives this option

enter image description here

B) If the product is not linked to any opportunity /record it will be directly deleted, but as it was associated to record and SF don't wanna mess with old opportunities that used this product so it will make as archived instead.

Salesforce has also written in RED that it is irreversible action thus you cannot do anything about it. You can read about it here.

You can also vote for the below idea, to make it supported in future.

Src: https://success.salesforce.com/ideaView?id=08730000000aeK0AAI

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.