0

I'm trying to make an http request, with the UserInfo.getSessionID(), in the authorization value, to

https://{{INSTANCE}}.salesforce.com/services/data/v43/ui-api/record-ui/{{sObjectID}}

and It replies the following.

System.CalloutException: Unable to tunnel through proxy. 
Proxy returns "HTTP/1.0 404 Not Found"

What I'm trying to do, is to make some REST calls, to the same instance, because of some objects I can't get access with Apex.

How could I do this? I tried doing it like this article, but it uses some urls for the callbacks, and I couldn't got it to work when I adapted the example to my instance.

Is this maybe because of a feature I need to activate for my sandbox? (I'm working in a sandbox)

4
  • 1
    Instead of 'v43' can you try 'v43.0' ? Also can you make sure {{sObjectID}} is a valid Id of record present in the org? Nov 29, 2018 at 20:14
  • Also are you able to access the above url on workbench.developerforce.com/restExplorer.php Nov 29, 2018 at 20:20
  • 2
    @PranayJaiswal You should add your first comment as an answer.
    – sfdcfox
    Nov 29, 2018 at 20:41
  • It's a valid ID, and I changed the 43 to 43.0, and still nothing, the same problem persist, I tried with 42-44, and nothing I still get the same error, I tested all the request I need, and how to extract the data, with the workbench, but I can't connect with apex.
    – ekiim
    Nov 29, 2018 at 23:53

1 Answer 1

2

The UI API Base URL is :

https://{{INSTANCE}}.salesforce.com/services/data/v43.0/ui-api/record-ui/{{sObjectID}}

Apparently, in the documentation, they have mentioned as

https://{your_instance}.salesforce.com/services/data/v{api_version}/ui-api

{api_version} is 42.0 , 43.0,44.0 etc

src:https://developer.salesforce.com/docs/atlas.en-us.uiapi.meta/uiapi/ui_api_get_started.htm

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .