0

Two organizations have the same entitlement process. One of them is outdated and I created a change set to update it. When deploying to the outdated org, I get this message.

When we try to delete an entitlement process that is in use by an Entitlement or a Case record, we get the error message that says that it cannot be deleted. In this situation, however, there are no Entitlement records that reference the process, and the cases that used to reference them were all deleted (it is a sandbox, so no problem with this).

I tried to create a new version for this process (versioning is enabled on both orgs), but I get the same message for the "v2" process.

Is there a way to deploy a change set containing an updated SLA process?

  • I think if you deploy the updated SLA process in the target org, you need to create a new version after actionation. Pls check – Santanu Boral Nov 28 '18 at 12:50
  • No, it does not work. I tried to create a new version before deploying the change set and I got the same error. – Renato Oliveira Nov 30 '18 at 16:28
1

It appears to be known issue without a fix. You have to create the new version in the intended org.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.