2

I've enabled Custom Fiscal Year in a Sandbox, in an attempt to set the first day of week as Saturday (requirement from client).

The structure I've chosen is 12 month / year Gregorian. When I preview the calendar under Custom FY, it shows Saturday as the first day of the week: enter image description here

However, when I go to Reports and choose the reporting period as This Week, it automatically selects the week starting with a Sunday: enter image description here

Is any additional configuration required anywhere to achieve the Saturday-first day configuration in Reports? What am I missing here?

Thank you.

1
  • Looks like a potential bug from Salesforce end. – Pranay Jaiswal Nov 27 '18 at 15:57
2

Whenever you see the term "This Week", the "first day of the week" is based on the calendar for the user's locale. It has nothing to do with custom fiscal years. To use fiscal weeks, look for filters like "This FW", and grouping options like "Fiscal Week." These are additional filters that are only available in orgs that have Custom Fiscal Years enabled.

4
  • Thanks for your reply sfdcfox. This thread suggests otherwise: success.salesforce.com/answers?id=90630000000gjhSAAQ. And when I setup Custom FY, it did provide me with the option to choose a start of the week. I'm wondering what the benefits of that would be. Basing it out of locale isn't an option and there are only 3 locales that support Saturday as the beginning of a week and none of them matches with the locale of my client. – miCRoSCoPiC_eaRthLinG Nov 28 '18 at 3:53
  • @miCRoSCoPiC_eaRthLinG Again, "This Week" refers to a calendar week, which depends on locale. What you're looking for are filters that include information about the Fiscal Work Week. In the Range drop down, you should have values like "This FW", and when grouping a summary/matrix, you can group by "Fiscal Week". There are new, additional filters you can use with Custom Fiscal Years, but the original filters still behave like they did before. – sfdcfox Nov 28 '18 at 4:21
  • Aah got you. Sorry about the terminology mixup. Thanks. – miCRoSCoPiC_eaRthLinG Nov 28 '18 at 4:24
  • @miCRoSCoPiC_eaRthLinG Not entirely your fault. I'll clarify my answer for future visitors. – sfdcfox Nov 28 '18 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.