0

I have four custom fields in a lead that are mandatory when creating an opportunity.

I have validation set up that if you try to create an opportunity it blocks you from saving if you have not filled in these four fields however you can bypass my validation rule if you click "convert" on the lead source.

Anyone know how to face this? I've seen a lot of articles but they appear to be out dated - I'm using Lightning.

Edit to add: Require Validation for Converted Lead is enabled, and here is my validation rule:

OR( 
ISNULL( A__c), 
ISNULL( CH__c), 
ISNULL( M__c), 
ISNULL ( P__c))

I had tried

IsConverted = TRUE 
&& 
OR( 
ISNULL( A__c ), 
ISNULL( Ch__c ), 
ISNULL ( M__c ), 
ISNULL ( P__c ) 
)

on the lead itself but that seems to have done nothing

1 Answer 1

2

See Lead validation rule not working when converting Leads:

Enable 'Require Validation for Converted Leads' in Salesforce Classic

  1. Go to your Name | Set-up | Customize | Leads | Settings.
  2. Enable Require validation for Converted Leads.
  3. Click Save.

Enable 'Require Validation for Converted Leads' in Lightning Experience

  1. Go to Setup.
  2. On the 'Home' Tab, look for Feature Settings | Marketing | Lead Settings.
  3. Click Edit and then modify Require Validation for Converted Leads.
  4. Click Save.
1
  • Thank you Adrian. We have Require Validation enabled but it's still not working - will update my question :)
    – Teresa
    Nov 26, 2018 at 16:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .