Actually, I created File Drop automation to import data into Data Extension. I dropped different files into the same file location. After the completion of automation flow - it imports data of the previous file again or sample set file data imports again. I have no idea what's happening! Anyone face this kind of issue.

  • 1
    I dropped File with Name LIke FILE_20181125.csv, FILE_20181126, both file has the same set of column & different data set for import.I dropped a File 1 and automation triggered import activity imports data into DE at end of process moved all data into other DE using ssjs script activity. After some time, I dropped File 2 with different dataset, import activity imports same data of Previous file (File 1).
    – user60922
    Commented Nov 26, 2018 at 14:22
  • Yes @Gortonington, I'm using "Begin With" - "FILE_" as a keyword. I need to multiple files. Even I removed all existing files and again dropped new files in it, import activity imports old data into data extension. I have no idea how it's happening?
    – user60922
    Commented Nov 27, 2018 at 13:56
  • Thanks, @Gortonington. I saw this in some other threads. what does it mean? can you help me get more detail about this like any documentation?
    – user60922
    Commented Nov 27, 2018 at 14:39
  • Here is a related SFSE answer I gave previously: (salesforce.stackexchange.com/questions/112907/…) and here is the help docs from SF (help.salesforce.com/…) Commented Nov 27, 2018 at 14:46
  • Hey @Gortonington, Still I getting old file data into Data extension - currently File Naming Pattern: %%FILENAME_FROM_TRIGGER%% in import activity & No File Pattern in File Drop setup. Any other suggestion
    – user60922
    Commented Nov 28, 2018 at 9:28

2 Answers 2


Use the date variables in your file name. I.e.: filename_%%month%%%%day%%%%year%%.csv

Your file name would then be named “filename_04132019.csv”

In the import activity settings there are two options you can choose:

  • Skip import if last import was less than [x] hours Fail import if file is older than [x] hours.
  • Allow System Buffer of [0] hours

The system will pick up the latest file and depending on your settings, will skip or fail imports if it doesn’t meet the criteria.


I'm having the same issue and I have the date variables in the file naming convention.

File Naming Pattern: Bayer_Insect_Forecast_%%Year%%%%Month%%%%Day%%.csv

I think uploading data on the same day confuses the system. I ran the automation the next day and it imported the correct, more recent file.

To be careful, I would remove or move the older data file before trying to import new data via SFMC automation activity, if you added both files on the same day.

  • It's not explicit, but you can include hour, minute and second as well to the file naming pattern Commented Sep 15, 2022 at 15:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .