0

I am trying to import jquery 2.2.4 in lightning component but i am facing issue with error code Custom Script Eval error [SecureDOMEvent: [object Event]{ key: {"namespace":"c"} }]

I Enabled Stricter Content Security Policy but still no luck. Do we have any alternative approach for this?

  • How did you import the script? – sfdcfox Nov 23 '18 at 7:58
  • @sfdcfox <ltng:require scripts="{!$Resource.jquery224}" afterScriptsLoaded="{!c.scriptsLoaded}"/> is my script to load – Salesforce developer Nov 23 '18 at 8:39
  • I just tested this in my org, jQuery 2.2.4 seems to be working just fine. Perhaps you're doing an illegal operation in your script? Can you please include what you've tried so far? – sfdcfox Nov 23 '18 at 8:49
1

Had this exact same issue and by using Locker Console, I identified my jQuery static resource was at fault. https://developer.salesforce.com/docs/component-library/tools/locker-service-console

Solution for me was to create a new static resource from https://code.jquery.com/

Hope it works for you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.