1

I am trying to deploy metadata to dev sandbox to another sandbox using Jenkins. I am getting an error as below:

[sf:deploy] Component Failures: [sf:deploy] 1. objects/User.object (User.ActiveUsers) -- Error: Could not resolve list view column: CORE.USERS.SAML_SUBJECT (line 406, column 16)

Please let us me if anyone faced the same issue and please suggest the solutions.

1
  • Can you open that list view xml and see the filters, if they are proper? Nov 21, 2018 at 18:04

2 Answers 2

0

Based on the column name "CORE.USERS.SAML_SUBJECT" it's complaining about something that is a standard user field in the source sandbox. If you're getting an error deploying to another sandbox it's likely that the field is only available if a specific feature is activated and it hasn't been activated in the target sandbox.

Most likely you'll need to first enabled SAML in the target org, go to setup and look for the single sign on settings, and then enable them. Once enabled give your deploy another try and see if it goes through.

Alternatively you might look at writing a pre-deploy script that strips that particular line from your User.object xml prior to deployment.

1

The existing answer has already been accepted but because the solution that worked for them has not been described:

We experienced the same error for scratch orgs and found the error was due to not having SAML Enabled set to true under Setup -> Single Sign-On Settings. After setting that to true, the error was fixed.

For making the settings change in the UI: https://help.salesforce.com/articleView?id=sso_saml.htm

For deploying the change, see SingleSignOnSettings in the SecuritySettings metadata https://developer.salesforce.com/docs/atlas.en-us.api_meta.meta/api_meta/meta_securitysettings.htm

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .