1

I have created custom button called "New Employee" on employee object and it is related with both account and contact objects via lookup relation. If i click on "New Employee" button on employee related list under Account detail page, working fine in both salesforce classic and lightning experience but not in partner portal.

/a03/e?CF00N342300009cAB8={!Account.Name}&CF00N342300009cAB8_lkid={!Account.Id}&CF00N90000009cUVB={!Contact.Name}&CF00N90000009cUVB_lkid={!Contact.Id}&retURL={!Account.Id}

Any help on this.

  • Can you provide an error message or a better explanation of what does happen when you click on the button in the partner portal? My best guess is permissions and configurations. – gNerb Nov 20 '18 at 14:43
  • If i click on button in parter portal nothing is happen (no action). – sfdccert Nov 20 '18 at 14:46
  • Are there any javascript errors in the browser dev console? – gNerb Nov 20 '18 at 20:08
  • @gNerb I am also facing same issue. custom list URL Button is not working Partner Portal, But its working in Classic and lIghtning. What are the permissions and Configurations i need to do. – Sfdcprgmr Nov 22 '18 at 6:33
  • @Sfdcprgmr , did you get any solution for this please? – N.. Jan 8 at 8:04
0

If your community url isn't at the root then this relative url will not work. i.e. if you community is on /partner/ then the link will not resolve correctly.. You will either need your community to sit on the root or change the button to work in a non-relative fashion. You can find this setting in the community workspace administration under settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.