0

I'm logged in to Trailhead as myself and working on this unit: https://trailhead.salesforce.com/content/learn/modules/apex_patterns_sl/apex_patterns_sl_apply_uow_principles

Scroll to 'Preparation for the Challenges'

Click on 'Deploy to Salesforce' under 'Deploy the ApexMocks open source library'

That takes me to this page https://githubsfdeploy.herokuapp.com/?owner=financialforcedev&repo=fflib-apex-mocks

Click on 'Login to Salesforce'

That gives me this page https://brave-badger-257278-dev-ed.my.salesforce.com/setup/secur/RemoteAccessErrorPage.apexp?oauth_error_code=1800

"We can't authorize you because of an OAuth error. For more information, contact your Salesforce administrator.

1800 : There was a problem in setting up your remote access"

The first time I tried it I hadn't launched Trailhead Playground so the login url above had the domain of my Trailhead login.

I launched Trailhead Playground and the login url then had the domain of my Trailhead Playground.

I have seen other similar questions but no conclusive explanation. I have tried it on my regular computer and also on another that has never been used for Trailhead or Salesforce before.

Any suggestions?

0

This is usually caused by some sort of configuration problem in the org you're using, and nothing to do with your computer. Try creating a new trailhead org and start fresh. There's a number of reasons why this could have happened, perhaps if you set up IP restrictions, blocked the app in the org, disabled permissions for installing new connected apps, etc. A default org should have none of these problems, while a trailhead org you've used for other trails (particularly anything involving security), you may have set one or more configurations that would block access to the installer. You might also want to check your login history on the user detail page, as that may provide additional information about the error, if you're really determined to try and fix the problem.

  • Thanks @sfdcfox. I created a brand new playground but same result. I can successfully login using OAuth via dataloader.io. Have opened a Trailhead Case. – MikeA Nov 11 '18 at 18:49
  • @MikeA That's probably for the best. Something seems wrong with the trailhead org itself, because I can run the heroku app on my personal dev sandbox without issue. – sfdcfox Nov 11 '18 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.