11

Hello i have a problem during Authorizing existing Sandbox via VS Code. I am using SFDX: Authorize an Org It will redirect me to Browser where i will put my credentials.

However it will redirect me to : http://localhost:1717/OauthRedirect?code=aPrxJCZZ9LWwfrAPFPjpwsStjScNnPvoX9jCrKFt7ZHDWIwPFmSoaqqiaJ6o3cdW_Cb97XjIPg%3D%3D&state=fc1ad902cf25

and it will display This page isn’t working localhost didn’t send any data. ERR_EMPTY_RESPONSE

Any idea how to fix this ? Many thanks !

1
  • 3
    Make sure you don't have a firewall or proxy that is interfering. This URL should work under normal circumstances.
    – sfdcfox
    Nov 5 '18 at 15:32
3

Please install Salesforce DX plugin using the following command and then try to authorize

sfdx plugins:install salesforcedx@48.22.11

This works for me.

1
  • This worked for me as well, I've tried setting the environment variable manually but it did not work. Great job! Mar 9 at 16:56
2

In my case, I deactivated the Windows Defender. Make sure that the port specification in the archive sfdx-project.json in your project doesn't have a port property or is different to 1717. Also, verify that the port 1717 is free using the command:

netstat -ano | findstr 1717 

If this port is in use so kill it

TASKKILL /F /PID 17956
3
1

I had this same issue for a few days and tried everything: 1. Killing process on Local host 1717 (node) 2. Switching from HTTP_Proxy to HTTPS_Proxy 3. Creating a connected app and changing the port used to establish connection.

Eventually what I found was I was doing all of this on my companies secure network, and there were certain permissions the IT administration had to lift to open access to certain ports.

FINAL Fix I just logged into a less secure wireless network e.g (went home, went to a coffee shop and tried the process again). Yeah, that was my fix hope its helpful.

0

Check and get your proxy settings. Set your proxy in the windows Environment local variable for "HTTP_PROXY" and "HTTPS_PROXY". You may need to log off your machine.

0

If you are trying to Authorizing an Org, but you are getting an error OR if it keeps loading.

Resolve it in 2 Steps:

  1. Open Task Manager -> Details -> Delete the process with name 'Node.exe'
  2. Set Microsoft Edge as your default browser.
2
  • Welcome to the Stack Exchange network! Please do not add signatures to your posts. Each post will have your profile card under it, and users who are curious can view your name, details, etc. there.
    – Adrian Larson
    Jul 21 '20 at 13:45
  • This did not work for me. both Firefox and Edge didn't return to the CLI, Firefox got further it authorised the Connected App, Edge did not offer me to authorise the app and also did not return to the CLI
    – NZ Dev
    Mar 1 at 10:55
0

Just to contribute, I've run into the same problem. In our case it was COMODO's functionality blocking the login. Actually, the Chrome window opened in Sandbox mode with a green border around for Chrome.

The solution for us was to Disable the option "Auto-Containment" while we did the authorization of the Org.

Once we did that, the login went ok in a regular Chrome window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.