0

Given:

  • Customer Community
  • Create Case Form component (not the newer Contact Support component)
  • Napili template
  • Authenticated customer community users only - no guest users
  • Community Users have profile P with read - create - edit on Cases
  • Attachments enabled on Create Case Form component
  • Observed starting Winter 19
  • No triggers on Attachment SObject

When

  • Authenticated community user clicks button that displays Create Case Form and completes form
  • Clicks on Add Attachment, selects file
  • Then clicks Submit button to submit the case w/ attachment

RESULT:

  • Case submitted but error in red box appears: Your case was submitted, but the attachment wasn't saved. Please create a new comment and attach the file to it.

So, how do I enable attachments to successfully upload?

0

Turns out that you need to enable a checkbox associated with attachments on Accounts and Contacts:

Setup | Communities Settings |Community Role and User Settings

"Lets customer users access notes and attachments" -- check true

enter image description here

This box had been unchecked for the org prior to Winter 19 yet evidence existed community users were able to upload attachments to Cases prior to Winter 19.

  • I added this checkbox and still no luck. Everything for me is exactly as it's described in the original quesiton – denvergreene Dec 10 at 22:30
  • @denvergreene - you should ask a new question posing your situation and reference this question/answer. This will get more community attention – cropredy Dec 11 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.