17

When attempting to generate a Query Plan in Developer Console in a Winter '19 org, I receive a generic "sObject Type 'xxxxx' is not supported" error.

For example, when I use a basic query such as:

SELECT Id, Name FROM Account

I receive "sObject Type 'Account' is not supported." See attached screenshot.

I have attempted to execute Query Plans on multiple objects but get the same error each time. If I click the 'Execute' button instead of the 'Query Plan' button, the query executes without issue.

I have tested in multiple orgs. This issue appears to have surfaced in Winter '19, as I use this feature regularly and have not had issues until now.

Is this a Developer Console bug, or has the Query Plan functionality been deprecated?

Query Plan issue in Developer Console in Winter '19 org

5
  • Looks like a bug to me. Have you contacted support?
    – sfdcfox
    Oct 23, 2018 at 21:27
  • I observe same in PROD org
    – cropredy
    Oct 23, 2018 at 22:35
  • I have given up on trying to work with Salesforce support, but will raise through other channels and try to get it logged as a known issue.
    – user52918
    Oct 24, 2018 at 0:50
  • @MikeTopalovich - This seems to have been resolved. I do remember seeing this when you asked this question, and while verifying this today, it worked fine.
    – Jayant Das
    Oct 30, 2018 at 1:55
  • It was a bug if anyone is curious was fixed last week. Oct 31, 2018 at 10:03

1 Answer 1

0

All indications are that this was a bug in the developer console and has since been resolved.

If it happens again, those

sObject Type 'X' is not supported.

error messages typically occur in the developer console when working against the wrong API. E.g. You accidentally have the "Use Tooling API" checkbox on and try to run a SOQL query for Accounts. Somewhere in the process of running the SOQL query the developer console would try and validate the underlying type was supported.

I can see in your screenshot that the checkbox was not ticked, so that would suggest the developer console was incorrectly running that same sort of validation even though you only wanted the query plan.

If the problem does recur, I'd suggest dropping back to the underlying REST API - Get Feedback on Query Performance.

Basically, rather than running your SOQL query with:

/vXX.X/query/?q=SOQL query

you switch to:

/vXX.X/query/?explain=SOQL query

One advantage of using the REST API directly is that you can also use a report or list view id in place of the SOQL query.


Oddly, I checked the Chrome dev tools from the dev console on NA64 and found the query plan button was sending the request to:

https://mydomain-dev-ed.my.salesforce.com/services/data/v44.0/tooling/query/?explain=Select%20Id%20from%20Account&_=1541054546697

The /v44.0/tooling/query/ in the URL seems odd, as I'd expect the query to be against the standard REST API rather than the tooling variant.

6
  • Unfortunately It happens on any tooling api connection performing a query too, not just dev console. I will test again tomorrow
    – Eric
    Nov 1, 2018 at 4:55
  • @Eric which pod/instance are you on? I had tried before posting and wasn't able to replicate the problem. So I assumed based on the similar reports from others that it had been resolved. I'm on NA64, which is currently Winter '19 Patch 10.5. If it is still a problem for you maybe we can narrow down the patch version. Nov 1, 2018 at 6:42
  • I will check today. I think the last time I tried may have been before the fix as it was sometime last week
    – Eric
    Nov 1, 2018 at 12:35
  • Yes I still see it. when GET endpoint (CS24 and Production) : /services/data/v37.0/tooling/query/?q=Select+Id+From+Account I get the response {"message":"sObject type 'Account' is not supported.","errorCode":"INVALID_TYPE"} - Response is same on v43 and V44. This is in a scratch Org. Dev console using tooling api is also showing the same error when you click use tooling API
    – Eric
    Nov 1, 2018 at 13:53
  • You need to use ?explain= rather than ?q= in the URL. I couldn't replicate it on CS66,CS50, or AP5. Nov 1, 2018 at 19:53

You must log in to answer this question.