When using the Flowscreen lightning component for Dependent picklists I am encountering an error. The components is configured:

  • Object API Name - the object where the picklists reside
  • Picklist 2 API Name aka the dependent picklist
  • Picklist 1 API Name aka the controlling picklist
  • Picklist 1 value is a variable set by the record lookup
  • Picklist 2 value is a variable set by the record lookup

When Running the flow:

  • The Controlling Picklist (Picklist 1 API Name) is populated by the Picklist 1 Value set by the variable from the lookup.
  • The Dependent Picklist (Picklist 2 API Name) is not populated by the Picklist 2 value set in the lookup.
  • There is an error displayed at the bottom of the flow:

"This page has an error. You might just need to refresh it. Error in $A.getCallback() [Cannot read property 'User Account Reset(s)' of null] Callback failed: serviceComponent://ui.interaction.runtime.components.controllers.DependentPicklistsController/ACTION$getDependencies Failing descriptor: {flowruntime:dependentPicklists}"

FYI - Winter 19 added Dependent picklists for Flowscreens as a lightning component.

Release Notes: https://releasenotes.docs.salesforce.com/en-us/winter19/release-notes/rn_forcecom_flow_design_screencmp_dependentpicklists.htm Release Readiness Live: https://www.youtube.com/watch?v=PSams5o8O10

  • 1
    What happens if you don't set the picklist values? Because that basic scenario is working fine for me.. Nov 14, 2018 at 21:55
  • Apparently the issue was with the lookup fields, swore I tried it, but apparently I was mistaken. @Guy Please add as the answer so I can set as correct. Thanks
    – Gabriel M
    Jan 31, 2019 at 4:47

3 Answers 3


The solution is simple actually it seems the standard DependentPicklist attempts to cache the initial values if they come directly from the object you have queried. To fix this issue, simply create a assignment element with the dependent and controlling picklist values as a text variable and use those values in Picklist 1 value, Picklist 2 value and even Picklist 3 value.


It appears to me this is a problem with the input values (the values coming from the lookups).

Try what happens if you don't set the picklist values. That basic scenario is working fine for me.

Then try showing the lookup values on the flow to analyze if they have the correct format etc.


I solved by updating the flow Api version to latest version

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .