0

I am trying to get Salesforce Marketing Cloud version info as the soap fault is returning Unplanned Outage in fault string and https://webservice.exacttarget.com/Service.asmx in fault factor can any body tell me what wrong am i doing here also i am testing this code on my local server so can this be an issue!

3

The marketing cloud is, as indicated by your SOAP response, experiencing an interruption.

When you suspect things aren't as they should be with a Salesforce product, the place to check is usually the "trust" site, https://trust.salesforce.com. For marketing cloud, that's https://trust.marketingcloud.com/

|improve this answer|||||
  • is it because of my code or any thing because today when i again run the code the soap fault message was different it is "Error Fetching http headers" – Owais Oct 19 '18 at 9:52
  • Now the message which is coming in fault string is " Error Fetching http headers" – Owais Oct 19 '18 at 11:47
  • Unplanned Outage message is continuously appearing in response to my request can you please help its urgent ! – Owais Oct 19 '18 at 12:58
  • in fault factor it is giving this URL "webservice.exacttarget.com/Service.asmx" – Owais Oct 19 '18 at 14:08
3

Salesforce Marketing Cloud is currently experiencing performance degradation that is impacting Stacks 1, 4, 5, 6, 7, 8, and 10 of the Marketing Cloud environment. During this performance degradation, customers may be experiencing difficulty in logging in to their Marketing Cloud services.

This is likely causing your issue. Please continue to monitor availability on https://trust.marketingcloud.com

If you continue to have issues once systems are restored then please report your question with some code samples

|improve this answer|||||
  • You mean this faultcode response "Unplanned Outage" is not because of any bug in my code ?? and can you please tell the time span in which the system will be restored ?? – Owais Oct 19 '18 at 10:24
  • There could be two separate issues. Yesterday's faults have been repaired, but if you are still having issues today then it could be your code. You will be best updating your question with snippets of your code so we can see what your attempting. – Gravitai Oct 19 '18 at 11:12
  • ok i am trying to fetch subscribers list i am using their code mentioned in the link : developer.salesforce.com/docs/… , the code that should be retrieving subscribers list should be $rrm = new ExactTarget_RetrieveRequestMsg(); $rrm->RetrieveRequest = $rr; $results = $client->Retrieve($rrm); – Owais Oct 19 '18 at 11:27
  • it is returning apifault std object =====> [apifault] => stdClass Object ( [Code] => 2 [Message] => Unplanned Outage [LogID] => 810017393 ) – Owais Oct 19 '18 at 11:35
  • after 5 minutes when i have again executed this script it says "Error Fetching http headers" in faultstring – Owais Oct 19 '18 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.