0

I have a custom salesforce object that I am trying to insert data into via the salesforce data loader tool. I can only see the object when I click export and click on "show all salesforce objects". When I do the same thing when I click on insert the object does not show up. Any ideas why I can't see this?

3
  • 2
    Verify the Object permission of the user’s profile – Santanu Boral Oct 18 '18 at 5:01
  • I would check the deployment status on the object itself to make sure it is deployed. Secondly I would check the profile of the person logging into the data loader to make sure they have access to the object. – Ayub Oct 18 '18 at 5:31
  • I have the admin profile and do have permission to all objects from what I can see, I just don't see that object listed online. I can only see it from the export tab. – MarkC5000 Oct 18 '18 at 11:37
0

You should give the custom object edit/modify all permission under object settings in profile of the user which is logged in the data loader. I made the following changes to a profile for a test object and gave it just read permission, I was able to view the object while exporting but not during insert or update operation.

enter image description here

2
  • I can't see the object from the online interface. I can only see it from the export tab in data loader. I have the administrator role and have permission to all objects but this one is not listed there. – MarkC5000 Oct 18 '18 at 11:35
  • I would urge you to login through UI and confirm the above permissions. Maybe your admin has cloned the administrator profile , made changes to it and assigned it to you. – user2246808 Oct 18 '18 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.