1

enter image description hereI am trying to complete the salesforce DX trail head Module for unlock Package. By the time of creating a scratch org as mentioned in the step it throws below error.

ERROR: No such column 'Settings' on sobject of type ScratchOrgInfo.

I am unable to rectify why this error is coming can someone help me out of this.

Please find the attached screenshot as well.

Command which i ran to create scratch org is below :

sfdx force:org:create --definitionfile config/project-scratch-def.json --durationdays 30 --setalias MyScratchOrg

Thanks & Regards, Ravi Ranjanenter image description here

  • Are you connected to more than one dev org through the CLI? The org you're using should have the dev hub enabled in order for you to create a scratch org. – John Towers Oct 17 '18 at 11:12
  • Hi @JohnTowers, I have enabled the devHub in my org and have added the connected devHub org screenshot as well. – Ravi Ranjan Oct 17 '18 at 11:32
  • It looks like it could be the settings key in your scratch org definition. It looks like it was added in v44.0 - the docs for Summer '18 don't have it and the org preferences were at the top level of the json object. Have you tried updating the CLI or using the Summer' 18 scratch org definition format? – John Towers Oct 17 '18 at 11:49
  • @JohnTowers It was a problem with CLI version only. I have upgrade the version and all the CLI commands are working fine. Thank you. – Ravi Ranjan Oct 18 '18 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.