1

I am not sure what happened to my logs. I am setting up/testing a JIT handler to create new users & contacts when they log in via SSO.

Yesterday, every time I logged in I would see a log entry that contained a full stack trace of the login event including any details or messages that I output to the log.

Today now all I see is:

Todays log?

It's lacking any detail or any of my messages that I am outputting. Why might my logs now be so barren?

  • Most likely, it's because of log level settings when the trace was configured. Can you post an example of the log details from yesterday vs the one from today? (Presuming you don't have the trace settings from yesterday vs today) – Mark Pond Oct 12 '18 at 0:07
  • Hey Mark, sorry I am new to this. I cant seem to find those logs. I look under debug in settings and nothing is listed and in the developer console I can only see what was logged since I last opened the console. Is there a better way to find them? – Jeremy Ragsdale Oct 12 '18 at 13:26
  • OK Update here. I am not sure why it worked but I changed the user that the JIT Handler executes as and now I am seeing the logs again. Both users are Admin users so either I screwed something up on the other user or there is some timeout that is happening that I am not aware of. If will update Monday, if it's still working then great, if not i'll have to dig deeper. – Jeremy Ragsdale Oct 12 '18 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.