1

I have the below setting in one of the profile:

<userPermissions>
    <enabled>false</enabled>
    <name>ManageCssUsers</name>
</userPermissions>


<objectPermissions>
    <allowCreate>false</allowCreate>
    <allowDelete>false</allowDelete>
    <allowEdit>false</allowEdit>
    <allowRead>true</allowRead>
    <modifyAllRecords>false</modifyAllRecords>
    <object>Contact</object>
    <viewAllRecords>true</viewAllRecords>
</objectPermissions>

But when I try to deploy this profile through ant migration I get an error saying - Manage Customer Users requires Edit Contact. I see it is because in target org 'Manage Customer Users' app permission is checked.

When deploying , should'nt the profile metadata change override the one in target env

  • permissions are additive in salesforce. – Pragati Jain Oct 11 '18 at 17:24
  • It under profile->app permission->Manage Customer user? Do you mean it cannot be changed using metadata? – SfdcBat Oct 11 '18 at 17:29
  • Yes, permission will be deployed in an additive manner. We can only grant permissions through metadata deploy. – Pragati Jain Oct 11 '18 at 17:34
  • Thanks!So to remove the permission, we have to do it manually? Is there any official document which describes this? – SfdcBat Oct 11 '18 at 17:35
1

So, According to Salesforce (https://developer.salesforce.com/docs/atlas.en-us.api_meta.meta/api_meta/meta_profile.htm) if you want to disable the permission on profile then you have to add code that explicitly indicates disabled permissions.For example, add the following code to the Profile metadata .xml file before deploying into a target org: <value>false</value>.

  • This permission (ManageCssUsers) corresponds to the "Edit Self-Service Users" checkbox on the profile. – Pragati Jain Oct 11 '18 at 18:07
  • Gotach , I see needs to be added to .xml of profile. – SfdcBat Oct 11 '18 at 18:08
  • One more thing releasenotes.docs.salesforce.com/en-us/summer18/release-notes/…. So Edit Self-Service Users is now renamed as Manage Customer Users. Glad to help you. – Pragati Jain Oct 11 '18 at 18:17
  • Thanks! But it seems like in my code base I don't store profile xml file. I only have xyzprofile.profile and not xyzprofile.xml – SfdcBat Oct 11 '18 at 18:21
  • It should be xyzprofile.profile not xyzprofile.xml – Pragati Jain Oct 11 '18 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.