I created a scratch org with the new Winter release.
After pushing my code without trouble, and updated it, I wanted to pull it to local files using :

sfdx force:source:pull --forceoverwrite -u myScratch

Now this error showed up :
ERROR: Metadata API received improper input. Please ensure file name and capitalization is correct. Load of metadata from db failed for metadata of type:AppMenu and file name:AppSwitcher.

Thing is, push works and I haven't modified an App.
Also note that it worked on a older scratch with Summer release.

I'll take any idea or advice.
Thank you for helping.

  • This may be related to a version mismatch. Try the following command: sfdx plugins:install salesforcedx@pre-release then try your command again. To go back to the current version, use salesforcedx@latest instead.
    – sfdcfox
    Oct 8 '18 at 23:59
  • Thank you for answering. I tried with pre-realease, latest or even an older version without success.
    – user43606
    Oct 9 '18 at 7:13

Here is a workaround for this SFDC Platform Winter19 bug

Create/update .forceignore file at the root of your SFDX Project, with the following content :

# List files or directories below to ignore them when running force:source:push, force:source:pull, and force:source:status
# More information: https://developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/sfdx_dev/sfdx_dev_exclude_source.htm


This doesn't solve the bug, but at least the sfdx force:source:pull doesn't crash

  • 2
    Thanks also! I just hit this same problem and your .forceignore entry fixed it! Nov 10 '18 at 0:07
  • 4
    It's a known issue that's scheduled for release in Summer'19 - success.salesforce.com/…
    – Tim Lewis
    Dec 12 '18 at 22:02

I had a similar issue with Flows and this the following fixed it for me. Maybe it applies for the AppSwitcher problem as well:

I changed the Version from 43 to 44 in "sfdx-project.json" file in my local repository and tried to pull the changes again.

Source: https://success.salesforce.com/answers?id=9063A0000019fxEQAQ

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.