0

I made a Integration user for our python backend, which utilizes a profile with API Only, and Modify All Data checked.

However, upon doing this, previous code that worked before is not working with this new profile.

The API is giving me this message back:

Unable to create/update fields: SuppliedEmail. Please check the security settings of this field and verify that it is read/write for your profile or permission set.

Does Modify All Data/API Only not give access to create a Case with this field? Or maybe my profile has more granular permissions that I didn't know about restricting it?

1

When Field Level Security is set to Hidden, the field cannot be inserted/updated/queried by the user attempting to perform any sort of operation with that field in play. Modify All Data, Edit Read Only Fields, Customize Application, and any other permissions will not grant the ability to see or edit values in this field. You'll need to go to the Field Level Security for the field and enable the Visible permission for that profile. You can do this from the profile in the Field Level Security section, or from the field in the Set Field Level Security feature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.