1

I am working on a visual force page that uses the slds styling. In the developer sandbox I was working on it displays fine as shows:

enter image description here

The code has been merged into a QA environment, and with the same code it is now not displaying the styles correctly and looks bland:

enter image description here

I have tried changing security settings and making sure the page is enabled for lightning, but I am getting stumped as to why this is occurring. If anyone has any ideas how to fix this please let me know! thank you!.

1
  • 1
    Is your sandbox on the same release as your developer edition (Summer '18 vs Winter '18)? Did you check the release notes for any changes? Are the metadata settings (e.g. API version) the same? A couple of screenshots are nice, but don't give us the full picture we need to assist you. You might also want to include some of the code, which may shed light on the situation. Please feel free to edit your question with additional information.
    – sfdcfox
    Commented Oct 3, 2018 at 14:41

1 Answer 1

2

If you are using lightningStylesheets = "true" and the environment that it is not working is in Winter 19 it is a 500 error on Salesforces part. If you inspect the browser when you load the visualforce page and look at the console you will see a 500 error relating to the css.

4
  • Yes the environment the issue is occurring in is Winter 19 and the visualforce code does indeed use lightningStylesheets=true. Do you know if this is an issue they will resolve quickly? Commented Oct 3, 2018 at 15:53
  • I raised a case with Salesforce, I will update this post when I hear back from them on timeline Commented Oct 3, 2018 at 16:04
  • I am seeing same issue, but I don't see a 500 error; i get an error in Chrome console, Refused to apply style from 'https://orgname--sandbox--c.cs11.visual.force.com/slds/css/UItiO8CvF2djTWcSa7CkFg/min/lightningstylesheets/one:oneNamespace,force:sldsTokens,force:base,force:sldsAvatarImages,force:oneSalesforceSkin,force:levelOneDensity,force:themeTokens,force:formFactorLarge,force:appThemeTokens/slds.css' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled. I'm sure it's the same issue, please keep us posted! Commented Oct 3, 2018 at 16:18
  • More info, which jives with @CalvinOKeefe's 500 error: I manually tried the slds.css url (from the network request panel of Chrome dev tools), it gives me an Internal Server Error. https://orgname--sandbox--c.cs11.visual.force.com/slds/css/UItiO8CvF2djTWcSa7CkFg/min/lightningstylesheets/one:oneNamespace,force:sldsTokens,force:base,force:sldsAvatarImages,force:oneSalesforceSkin,force:levelOneDensity,force:themeTokens,force:formFactorLarge,force:appThemeTokens/slds.css Note that i've obscured the My Salesforce part of the URL at client request. Commented Oct 3, 2018 at 16:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .