1

I attempted to follow the help pages will no luck. this message appears to default to a version of php of its choosing then chastises me for picking an out of date version.

I am using php version 7.0.29 on my local server. I ran composer update but it did not create a lock file as the help pages suggested

How do i get rid of this message?

Console

closed as off-topic by Pranay Jaiswal, Himanshu, glls, battery.cord, Mr.Frodo Oct 14 '18 at 14:09

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Programming questions not specific to Salesforce are off-topic here, but can be asked on Stack Overflow." – Pranay Jaiswal, Himanshu, glls, battery.cord, Mr.Frodo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    There is still an open discussion about if Heroku questions are on topic here. Regardless of whether they are or not, you should always include error messages as text rather than images. It greatly improves accessibility and search. – Adrian Larson Sep 20 '18 at 3:50
  • What do you have in your composer.json? Can you add the relevant part to the question? – Neil Middleton Sep 20 '18 at 11:58
  • {} that's it, the documentation says I don't even have to have anything but it errors if i don't have the brackets – user9782218 Sep 20 '18 at 12:44
  • this tools strips all white space. to the about is supposed to show just the contents as two brackets then newline but this text box script strips it out – user9782218 Sep 20 '18 at 12:45
  • Adrian Larson - Heroku sends you to this forum as the only support available for free users. personally i find heroku overly complicated and poorly documented but I am required to use it for a school assignment – user9782218 Sep 20 '18 at 12:48
0

I spoke with our PHP team. You're running on an older Heroku stack (not heroku-18). These older stacks will default to PHP 5, unless you specify a version in composer. So if you were to upgrade to heroku-18, the default would be PHP 7.2 Either way, it's highly recommended that you specify a version in your composer file.

  • How do I specify to PHP version in my composer file while I slumming it on the older stack? – user9782218 Sep 21 '18 at 2:54
  • so I updated my composer to: – user9782218 Sep 22 '18 at 18:04
  • { "require": { "php": "~7.2.0" } } ran composer update but it complained I was running 5.6.35 but phpinfo() shows I am running 7.2.4. That failed so no I can't push because I have no composer lock file – user9782218 Sep 22 '18 at 18:08
  • apparently my heroku install has an old version of php. my WAMP environment where i develop has 7.2.4. how do I upgrade the php version that heroku is looking at? – user9782218 Sep 22 '18 at 18:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.