1

I have some issues while trying to filter my subscribers dataset. First of all, the response properties don't correspond to the request properties:

...
<RetrieveRequest>
         <ObjectType>Subscriber</ObjectType>
         <Properties>ID</Properties>
            <Properties>PartnerKey</Properties>
            <Properties>CreatedDate</Properties>
            <Properties>Client.ID</Properties>
            <Properties>EmailAddress</Properties>
            <Properties>SubscriberKey</Properties>
            <Properties>UnsubscribedDate</Properties>
            <Properties>Status</Properties>
            <Properties>EmailTypePreference</Properties>
            <Properties>CreatedDate</Properties>         
</RetrieveRequest>
...

The response I get:

...
<RetrieveResponseMsg xmlns="http://exacttarget.com/wsdl/partnerAPI">
         <OverallStatus>MoreDataAvailable</OverallStatus>
         <RequestID>f09724cb-abb2-4cd7-b3d7-be29a3dbfcbb</RequestID>
         <Results xsi:type="Subscriber">
            <Client>
               <ID>7213480</ID>
            </Client>
            <PartnerKey/>
            <CreatedDate>2015-07-09T10:25:00</CreatedDate>
            <ID>7531894</ID>
            <ObjectID xsi:nil="true"/>
            <EmailAddress>Abuzzi@bancafideuram.it</EmailAddress>
            <Attributes>
               <Name>First Name</Name>
               <Value/>
            </Attributes>
            <Attributes>
               <Name>Last Name</Name>
               <Value/>
            </Attributes>
            <Attributes>
               <Name>CAP</Name>
               <Value/>
            </Attributes>
            <Attributes>
               <Name>Locale</Name>
               <Value>bg-bg</Value>
            </Attributes>
            <SubscriberKey>Abuzzi@bancafideuram.it</SubscriberKey>
            <Status>Active</Status>
            <EmailTypePreference>HTML</EmailTypePreference>
         </Results>
</RetrieveRequest>
...

Would anyone know the reason of it?

Also I'd like to filter by "Locale" property in "Attributes", do anyone know how to do it? I tried to do it like that:

<Filter xsi:type="SimpleFilterPart">
           <Property>Attributes.Locale</Property>
           <SimpleOperator>equals</SimpleOperator>
           <Value>az-az</Value>
</Filter>

But obviously it doesn't work.

Thank you for your help.

2

When you include ID as a property, the response returns all Profile Attributes for your Subscribers, in addition to the other properties you requested.

You can't use a SimpleFilterPart to filter by a Profile Attribute. If you need to do this, then you have to create a FilterDefinition Object.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.