0

I am trying to download the latest version of the force.com migration tool (sometimes called the ANT migration tool.)

The download page seems to link to the Summer 2016 version of the tool (see errors below), despite claiming to link to the Summer 2018 version.

When I configure package.xml and run the .jar like so:

ant retrieveUnpackaged -lib path/to/ant-salesforce.jar

I get errors like this:

[sf:retrieve] package.xml - API version Summer '16 does not have access to Lightning Pages of type CommObjectPage

Note that this error message is not referring to the API version in the retrieve source sandbox. The sandbox API version is Winter '19.

I've been looking for a while now and still haven't found an alternative download link that correctly points at the Summer 2018 migration tool. Can anyone help?

4

here is a link to download ant migration tool 43.0

looks like your problem is, that you selected 37.0 API versdion on the top left corner.

enter image description here

| improve this answer | |
  • Thanks. Tried your direct download link for version 43. Unfortunately, I got the same Summer 16 error messages. I've also checked the version in the top left as you suggested-- all pointing at version 43. – Nick Sep 17 '18 at 8:32
  • @Nick what API version is mentioned in your package.xml? – Oleksandr Berehovskyi Sep 17 '18 at 8:33
  • 1
    The API version was sert at 37.0. When I changed it to 43.0 the errors disappeared. Many thanks! – Nick Sep 17 '18 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.