I have a quite complex package that I can not get installed on any org (Sandbox, Production, Scratch Org) ... The install always fails with the following error message:

Install failed, Details: Your requested install failed. Please try this again.  None of the data or setup information in your salesforce.com organization should have been affected by this error.  If this error persists, contact salesforce.com Support through your normal channels and reference number: 1348471944-30290 (1259856384)
  • The package source works perfectly, I have >95% test coverage and all tests succeed
  • No problem pushing/pulling the whole directory to a brand new scratch org
  • No package dependencies with installation keys (even though some older versions of packages, this package depends on, have had installation keys)

Does anybody has an idea, why this install fails? I found no information whatsoever, googeling the error-id 1259856384

3 Answers 3


Found out it was due to some testSuites I added to group my tests. After removing them from source (folder: testSuites) and re-compiling a new package version, it worked.


When I got this error it was because I had some of the same metadata in a seperate unrelated package already installed in the org.


Does there happen to be a Certificate in your package as I received the same error code - SFDX - Can certificates in Unlocked Packages be installed?

When I removed the Certificate from the package, it installed successfully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .