I have written my own custom lead conversion by adding separate button and its working fine, but from lead status path button it is still working as default. I want to remove this "convert" option from the lead status path. Please suggest me to resolve the issue.

2 Answers 2


The options you see on the Path component is driven by the Lead Status or any other field.

To show or hide a value from the Path, you need to configure the status field that you can use only respective values. The best way here is to utilize a combination of Lead Process, Record Type and Path together to achieve efficiency for the overall sales process.

You can refer to the trailhead Optimize Sales Processes Using Path to find more about it.

  • I just made a custom conversion process by code. Now just want to remove options which convert lead using the default process.
    – user54548
    Sep 12, 2018 at 13:37
  • I am not sure if I follow this, but if you want to remove anything from Path on Lead Status field, that should be from the respective field. If you have already customized the flow, wouldn't it be better to just remove the Path component from the page itself?
    – Jayant Das
    Sep 12, 2018 at 13:38

All you need is:-

step 1:- Open the record detail in Lightning
step 2:- Go to setup and select Edit page
step 3:- Lightning App builder will open, now you need to click on the path component and then in the right side, the setting for path component will open
Step 4:- check to hide path update button and save your page 

The Button will get disappear.

Hope it helps You.

  • Thanks, Sanket. But by doing this User will not be able to update lead status from the path. I just to remove "converted" option from the path.
    – user54548
    Sep 12, 2018 at 13:06
  • Yes, you will lose the ability to change the status using path. I could not see any other option override this button. Maybe you can say the salesforce limitation. Even if you override the convert button with your component, sales path button will open the default convert page, not the custom one which you have override. Sep 12, 2018 at 13:42

You must log in to answer this question.