0

I am getting error while filling in assigned to field of new task of Account.When I am saving the task record, I am getting No User found error and not able to save the record. User that I have filled in is available in Org and is active. Please help. PFB error screenshot. ​enter image description here

  • what's the first name of this user?? – Abhishek Daware Sep 12 '18 at 6:11
  • Try to use lookup icon beside the field and select user instead of writing the name of the user in the lookup field. – sanket kumar Sep 12 '18 at 6:23
0

The user has a first name containing spaces, that the reason lookup fields do not work properly. When you type the full name of the user as "First Name last" and clicking saves, then error "No matching users found", even if the user exists with the same name.

If you type the name and the username pops up under "my recent items" then the assignment will work.

Reason for lookup fields not working in these scenarios are Search stores each string for matching and uses spaces to separate those strings. If you do not indicate that you want to find two strings in sequence, separated by a space in your search by using quote marks, the search will match those strings no matter what order they appear in.

Workarounds :

  1. Use Lookup icon for selection.
  2. Get even more control over your search results with wildcards and operators. Refer this for more details Exact match keyword search in Global Search

An idea exists for this issue. Please have a look on same Make Contact, User, Lead lookups work properly when first names contain space

  • If this answer works for you then feel free to accept this answer. – Abhishek Daware Sep 12 '18 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.