0

I did the following:

  1. In my scratch org I created a custom field (on a Standard Object).
  2. Then I executed force:source:pull so I had that custom field in my project folder.
  3. I created a new scratch org and pushed the sources into that scratch org.
  4. I deleted in that scratch org the custom field.
  5. I executed force:source:pull but it says "No results found", same with force:source:status

Interestingly a deleted field on a custom object does get pulled, but not a custom field on a standard object (at least that's what it looks like according to my tests).

Is that behaviour intended, am I doing something wrong or is it a bug?

The problem is, that I cannot simply delete the field in my project-folder, because then I have to manually edit all the profiles and layouts and delete the field-reference there as well, because otherwise there are errors when trying to push the sources into a new scratch org.

0

Can you please check below link of @notmyf4ulty .. She already raised the ticket to salesforce ... Salesforce DX: How to track custom objects' changes in custom profiles?

| improve this answer | |
  • Hope this helped you..if yes please vote – Ashwini Dengi Sep 6 '18 at 11:20
  • Yes. Not the exact same problem, but basically it seems to be the same issue... thank you! – martes Sep 7 '18 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.