I've added a "New Action" in Account / Buttons, Links, and Actions. I've added the action/button to the Page Layout and it does show for me. It runs a Lightning Component that creates a customized Order record. Non-admins cannot directly create Order objects, and the component is there to do that for them correctly. But they can't see it, I created a non-admin user to make sure.

My component has access="global", the apex controller class has public with sharing.

The Page Layout is permitted to the users, any advice is appreciated.


5 Answers 5


Why would a user not see Global or Quick Actions?

Despite the User being assigned a Page layout with Global or Quick Actions selected to display, they cannot see them in the Feed. This can occur when the Global or Quick Actions are creating a Record with a Recordtype to which the User does not have access.

This is expected as Buttons, links, and actions only display if the User has the appropriate permissions to utilize them.


To resolve this issue, perform one of the below actions:

  1. Assign the Record type being used by the action to the User's Profile.

  2. Change the Record type that the Action is using to one assigned to the User.

  3. Create a New Action that uses a Record type available to the User.

Reference:- https://help.salesforce.com/articleView?id=000213519&type=1

Further Explanation:-

  • If users don’t have access to a particular record type, actions that are assigned to that record type aren’t available to them. For example, let’s say that you have a page layout that contains a mix of actions—some have no record type assigned and some are assigned to Record Type A. Users without access to Record Type A see only the nonassigned actions when they visit the page.


Don’t assign actions to the Master record type. The Master record type is a placeholder record type that’s assigned when your organization is created.

If you have default global actions in your organization and you’re using record types, your users might not be able to see all the default actions that are assigned to a page layout.

Default global actions are assigned to the Master record type, which isn’t accessible to most profiles. As a result, default global actions with the Master record type that are associated with target objects that have record types configured aren’t available for most users. To fix this issue, edit the default global actions associated with those objects and reassign them to a different record type.


Hope it helps you.

  • I appreciate the effort, I will for sure keep them in mind for future. But I found my answer here: help.salesforce.com/… Search: "The Allow Access to Customized Actions system permission"
    – Mac A.
    Commented Sep 6, 2018 at 17:07
  • Welcome, @MacA. There are multiple things for a problem and we need to take care. Commented Sep 6, 2018 at 17:11

I had this same issue. I even logged a case with Salesforce about it because it wasn't straightforward.

It occurs when the sysadmin profile has a default record type of Master (for the object) when there is a custom record type.

  • 3
    So what's the solution? You've described the problem without explaining what to do about it (or where).
    – isherwood
    Commented Dec 9, 2020 at 16:54

I had this same issue, but no recordType was involved. This custom action calls a Flow. The user profile did not have the permission to Run Flows. As soon as that was enabled, the Action button appeared.


If the custom action is used to do actions on a related object, eg. create a record, then it could be that field-level permission on the Lookup is not set for that particular profile.


One of the permissions de check is "Read" and "Write" access to the lookup field (parent object) on the child object.

  • I just spend 3 hours trying to make the custom "New Case" action button on Account object available to all users. I reviewed EVERYTHING from profile permissions, to user permissions, to global settings, page layouts, record types, etc., and thanks to the answer above, I finally un-checked the "Read-only" permission for Account Name field on Case object for all users, and the New Case button miraculously appeared for them. This is mind blowing. I would have never figured it out on my own. Thank you Riadh Benfreha.
    – Milena
    Commented Apr 15 at 21:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .