2

I am desperately looking for some answers to this considering Salesforce Support is non-responsive at the moment and this is time-sensitive.

We are currently launching/transferring a majority of our network on to a new Salesforce org this weekend. As part of that effort we have been doing tons of data migration.

Unfortunately, due to a lack of licenses until the go-live weekend, at the time of migrating opportunities and quotes we had opted to assign the Quote.OwnerID to one of our developers for the time while housing the actually original quote owners in a custom Owner_Id__c field. The expectation was that once the licenses were available we would simply transfer the values over to the proper owner.

When attempting to assign Quote.Owner_Id__c to Quote.OwnerId, we came across the following error:

"FIELD_INTEGRITY_EXCEPTION: Can't change quote owner. Enable quotes without parent opportunities.: Owner ID"

This happens through both the UI and via anonymous apex. I’ve been googling for some workarounds but from what I see here: https://success.salesforce.com/ideaView?id=0873A0000003UXQQA2

It looks like the error message is telling me that the only work around is this much needed feature request that is a month later than we need it (seriously?!).

The only response Salesforce has sent over in the past 48 hours is, make sure Quote has a parent Opportunity associated to it. One thing I noticed that was a potential concern was that the Opportunity.OwnerId had the same issue, likewise assigned to the developer, which I believed could have been an issue. I've since migrated Opportunity.Owner_Id__c to Opportunity.OwnerId and reattempted adjusting the Quote and still the same error.

ANY further insight would be much appreciated. Thank you!

0

I'm running in to the same thing problem-the quotes owner name field isn't editable. Did you ever figure it out Xtremefaith?

  • I had opened a case with Salesforce, unfortunately besides the redundant tasks they had me try it appears a fix magically appeared (I believe related to this: success.salesforce.com/ideaView?id=0873A0000003UXQQA2). I believe Support had to enable me for pilot access, otherwise you can checkout "quotes without opportunities" feature under Setup >> Quotes >> Quote Settings. This was not an instant fix but sometime afterwards it appears to have worked. – Xtremefaith Nov 13 '18 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.