0

I have configured Salesforce Survey in the org. Survey itself is working fine for both internal and external users.

I have to display this survey to end-user when the chat is ended. I have used Post-Chat URL and used "external" survey link to be displayed. Theoretically, all should work without any hassle, but I am receiving this weird error:

while(1); */{"message":"Invalid request, no message"}/ERROR/

I am not sure what is going on and what wrong am I doing here?

4
  • What is the URL you are using? Did you check with any static URL like yahoo.com?
    – Saroj Bera
    Aug 30 '18 at 13:16
  • Just checked, "yahoo.com" just worked fine. :-|
    – Mahmood
    Aug 30 '18 at 13:21
  • What is the URL you are using?
    – Saroj Bera
    Aug 30 '18 at 13:33
  • It is my SF community URL. https://XXXXXXX.XXXX.force.com/survey/runtimeApp.app?invitationId=0Kin00000000001&surveyName=testing_survey&UUID=5ccc2c12-68d8-4f9d-99eb-259279ea9ebb
    – Mahmood
    Aug 30 '18 at 13:41
0

For some odd reason, Salesforce Survey's "External" survey link didn't work with Post-Chat form url. Since community enablement is pre-requisite for Salesforce Surveys therefore I thought of a workaround to send the survey to end-users once chat is finished, by following the steps given below:

  • I added a new page on community, named it "Satisfaction Survey" (you can name it as you wish)
  • Put the Survey component on page, on modified community layout, without header and footer, so the end-user won't have a look-n-feel of a community.
  • Publish the community
  • Get the URL of the page you just added and put it in the post-chat form URL and it worked like a charm!
5
  • can i know which URL you have used the once the invite generates or the community URL?
    – Krishna
    Jan 3 '19 at 0:28
  • @Krishna URL used: XXXXXXX.XXXX.force.com/survey/…
    – Mahmood
    Jan 3 '19 at 5:35
  • @Mahmood Thanks for posting the answer. Currently, I'm facing the same issue. I have followed your approach, but I am getting this error in the console "Refused to display "actual URL xxx.force.com/survy" in a frame because an ancestor violates the following Content Security Policy directive: "frame-ancestors 'self'". Any thoughts on this? Mar 25 '20 at 21:34
  • You need to check if your survey is working on its own. Second, check your browser's console for any errors. Finally, if your requirements and problem are different than those mentioned here, I suggest you to create another question with relevant details and we'll be happy to help you.
    – Mahmood
    Mar 25 '20 at 21:50
  • @Mahmood Sure, Thank you so much for your inputs. Mar 25 '20 at 22:01
0

Salesforce does not provide any direct documentation for this, what worked for me, using Salesforce sites:

  • Implement either a Salesforce Community or Salesforce site.com, create a post chat visualforce page and include it in the site/community. Make the access public and on mobile, etc.
  • Go to your site setting (salesforce) change Clickjack Protection Level to "Allow framing of site or community pages on external domains (Good protection)"
  • Add your website to Whitelisted Domains for Inline Frames in site setting page, this needs to be the webpage where the embedded service is hosted.
  • Add the force.com site URL (which should be accessible without login/as public) to the chat button Post Chat URL eg.https://*.force.com//

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.