6

I have a simple process builder on opportunity product (on create&edit) to pull value of related Products Family on to a text field (Product_Family_For_Backend_Use) on opportunity product. The process builder was working fine but sometimes its showing error :

Error element myDecision (FlowDecision). Formula result is data type (Object), incompatible with expected data type (Text).
Flow Details
Flow Name: Update_Product_Family_For_Backend_Use_on_opportunity_product
Type: Record Change Process
Version: 1
Status: Active
Org: Kaptivo Inc (00D1I000002L326)
Flow Interview Details
Interview Label: Update_Product_Family_For_Backend_Use_on_opportunity_product-1_InterviewLabel
Current User: Celeste Henkelmann (0051I000000nyMB)
Start time: 8/28/2018 7:57 AM
Duration: 0 seconds
How the Interview Started
Celeste Henkelmann (0051I000000nyMB) started the flow interview.
Some of this flow's variables were set when the interview started.
myVariable_old = null
myVariable_current = 00k1I00000VdcjbQAB
ASSIGNMENT: myVariable_waitStartTimeAssignment
{!myVariable_waitStartTimeVariable} Equals {!$Flow.CurrentDateTime}
Result
{!myVariable_waitStartTimeVariable} = "8/28/2018 7:57 AM"
Salesforce Error ID: 1730798143-47888 (56480063)

Decision Element:-

enter image description here

Update Action:-

enter image description here

Any suggestions how this could be happening some times and not others? Also what could be the problem.

other than one custom text field.... all other fields & object used in this process are standard..

Thanks for your time!

9
  • Can you update the question with criteria and action of your process builder? So that we can have the better picture to analyse your problem.I guess the problem is with them. Commented Aug 29, 2018 at 5:18
  • Hi Sanket, I have updated question with screenshots. Commented Aug 29, 2018 at 5:50
  • Why don't you use a formula field. Anything on the product object is available on the opportunity line item using a formula without the need for a worklow? Commented Aug 31, 2018 at 19:56
  • because i want the resulted field to use in rollup summary. And if i do the formula then i can't do rolloup. Commented Aug 31, 2018 at 19:58
  • 1
    Also, may want to try using a workflow rule. I found they are less prone to strange errors compared to PB. Your logic is pretty straightforward and should work perfectly. Commented Aug 31, 2018 at 20:07

3 Answers 3

3
+25

I'm not sure why the problem is occurring, but following approach might solve your issue permanently.

First, no need to put a condition like Opportunity.Product2.Id is not null, because, Opportunity line item doesn't exist without a product. So, it should be No criteria—just execute the actions!

Secondly, for update action, use formula of return type Text and refer the product family.

update action

1
  • Tried...same error. Commented Sep 6, 2018 at 8:57
0

I think the problem is with updating the field. You are supposed to wrap your Product Family field in TEXT function. Product Family field is being treated as the Object and your formula is expecting a text.

So change update type to Formula and in the formula builder use the following -

Text([OpportunityLineItem].Product2.Family)

I hope this will resolve the issue.

2
  • Yes...i tried it but same error. Commented Sep 6, 2018 at 8:58
  • Do you have any other workflow/formula/process builder on this object? I will check them since everything seems to be okay with this PB. Commented Sep 6, 2018 at 11:41
0

I had this issue when changing the API name of one of the fields used in the flow. The solution is to clone the process and save it making sure it had the new API name in it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .