We have setup an Entitlement Process in our org which upon hitting milestones performs a number of field updates on the Case record. These checkboxes correctly update when the milestone is hit, however Process Builders that are supposed to run off these checkboxes do not fire. We have confirmed that the Process Builder fires when the checkboxes are manually checked. We also tried creating a trigger that fires off the checkbox and checks another, however firing a Process Builder off this secondary checkbox also fails to run the Process Builder.

We have ensured that 're-evaluate workflow rules' is enabled on both the field update actions and tried setting the Process Builder to allow for recursion, neither of these settings resolve the issue.

We suspect this may be an order of operations issue? we need a work around.


It is a reported known issue, refer to: https://success.salesforce.com/issues_view?id=a1p30000000SU70AAG


Order of execution sounds like it may be the cause. You could test making the field update a scheduled action with a delay of one minute instead of an immediate action. That might resolve this issue.

  • Hey Scott, yes this is our suspicion as well. I don't think it's possible to add delays in the milestone action and delays in the PB doesn't work. Our dev has built a workaround with a trigger that calls a future context method to update a secondary field. This resets the whole execution context, i.e. starts over from the beginning as a pure field update, not an update from an entitlement action. This feels like a bug that should be possible declaratively. – Jonathan Mills Aug 29 '18 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.