3

I don't see the "API only" permission in my Production org (Enterprise Edition) in a custom profile, which is awkward.

I checked this post - How to create an API only user, however I haven't found an explanation to my question.

enter image description here

enter image description here

Why this permission is not visible?

Update

As suggested I switched to the Enhanced Profile User Interface. Still no luck:

enter image description here

  • how this custom profile has been created? Is that cloned from any OOTB profiles? – Santanu Boral Aug 27 '18 at 11:58
  • Unfortunately, I don't know how that profile was created. I assume that it was cloned from some of the standard profiles. What does OOTB stand for, by the way? – Eduard Aug 27 '18 at 12:02
  • Out of the box. – Santanu Boral Aug 27 '18 at 12:29
  • 1
    I noticed that the license type is "Salesforce Platform" and not standard Salesforce. I think the Salesforce Platform license cannot be set as an API Only user. – David Cheng Aug 30 '18 at 16:49
3

"Api Only User" is a system permission available in "System Permission" when your Enhanced Profile User Interface is enabled. Refer for more details here on the documentation.

To enable the Enhanced Profile User Interface, you can refer to the documentation here.

Once enabled, your profile view will look something as below: enter image description here

You can then enable "Api Only user" permission in there, as in the below screenshot: enter image description here


NOTE: If you don't see this option in system permission on your profile, you may like to reach out to Salesforce support. I verified in an unlimited edition on standard and custom profiles and could see this option available on all profiles in the respective section.

| improve this answer | |
  • Thanks. Unfortunately, it didn't help. Please see my updated question. – Eduard Aug 27 '18 at 14:45
  • You may like to reach out to the support. Because that's the place where you will be able to set that option. As of why that option is not available, I was reviewing an unlimited edition and could see that available for all standard or cloned profiles. – Jayant Das Aug 27 '18 at 15:08
  • Yeah, that seems to be my last resort. The only "but" is I am not allowed to create support cases for my client. Thanks for your help anyway. – Eduard Aug 27 '18 at 15:39
  • Probably providing them with the details so that someone can open one. I cannot find anything around that says if there's a reason of that permission not shown in the system permissions :( – Jayant Das Aug 27 '18 at 15:40
  • The API Only option is not available for "Salesforce Platform" licenses. Thats why the checkbox is missing. – codeulike Jan 31 at 12:02
3

As David Cheng said in the comments, the reason you are not seeing the 'API Only User' option in this case is because the license type is "Salesforce Platform". For some obscure reason, you can only choose 'API Only' on full "Salesforce" licenses, not the cheaper "Salesforce Platform" ones.

Source: See discussion here about how Salesforce should allow an API Only Platform user: https://success.salesforce.com/ideaView?id=08730000000YSqsAAG

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.