0

I have created a Canvas app and it runs perfectly on SF developer account 1.
In SF developer account 1 it appears on the Chatter tab as a button in the left menu (classic mode).
I create a package and upload it.
I then login to SF developer account 2 to install the Canvas app from the installation URL.
It says installation worked for SF developer account 2.
The canvas app appears in the App menu; however when I select it, nothing happens.
No error message, no iframe container and it does not appear as a button in the left menu of the Chatter tab so that users can launch it.

Can someone please provide a solution or things to try?  Thanks!

0

Wow SalesForce, this is painful (very frustrating system). I switched to SF Developer 2 account and tried to setup another package; but it said I already had one (did not) and SF limits you to one managed package. So I created a Namespace and then I was able to create a Managed package for my Canvas app. I uploaded it and installed it on SF Developer 1.

The install message warned my that it was a Beta app and blah, blah, blah. So I accepted the warnings and it worked, well kinda. If you have 2 accounts, SF gets confused and refused to run the canvas app on SF Developer 1...so I checked the Chrome browser dev console and there is an error message regarding an X Frame issue? I click the URL in the Chrome console and I get the expected Oauth dialog. I then Allow the new app to run and everything is peachy.

So try the Namespace thing if your canvas app does not appear in a button in the left menu/sidebar.

https://developer.salesforce.com/docs/atlas.en-us.lightning.meta/lightning/namespaces_creating.htm#!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.