1

Getting below error when trying to update mavensmate project credentials

"MavensMate is unable to connect to Salesforce. Please re-authenticate to continue. This can happen if your access/refresh token have been revoked or if MavensMate is unable to retrieve your credentials from secure storage"

I have also tried with creating new project and connecting to salesforce instance but still getting the same error.

After trying to update credentials many times, it shows "Internal Server Error" on mavensmate desktop window.

Please help me to resolve.

Thanks.

1
  • Are you able to connect to Salesforce using the exact same credentials via, for example, Eclipse or Workbench?
    – David Reed
    Aug 23, 2018 at 14:35

1 Answer 1

1

Try this, it worked for me after banging my head against the wall for hours: https://github.com/desktop/desktop/issues/3263#issuecomment-344590213

It sure looks like something's screwy with Keychain.

Try opening Keychain Access.app. Right-click on the login keychain and try locking it and then unlocking it again.

1
  • 1
    Hi Jeremy, welcome to SFSE. If this link answers the question, please edit this post to include the essential content here. Links can go dead over time, making link only answers low quality (they are often deleted).
    – Adrian Larson
    Jan 30, 2019 at 22:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .