1

I'm trying to turn off the DEBUG messages from Data Loader CLI's output when running.

As per the documentation I have set sfdc.debugMessages to false, but it's still outputting them. I have set sfdc.debugMessagesFile to various settings, including:

  • an actual file location
  • an empty value
  • not setting it at all

Nothing I've tried so far is having any effect.

If it makes any kind of difference for context, I'm calling the DataLoader JAR from ANT.

I've looked online but haven't been able to find many scenarios that are the same, nor have the resolutions from those scenarios helped me.

Has anyone else faced this same issue and found ways to resolve it?

1

The resolution was found in this question.

In the log-conf.xml, I changed

       <priority value ="@LOG_LEVEL@" />

to

       <priority value ="info" />

Now I'm only seeing INFO and ERROR messages, which is what I want. I don't know why it wasn't respecting the settings in process-conf.xml, however.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.