1

I am trying to deploy a dashboard through METADATA API and I am getting this error:

dashboards/Sales_Pipeline/lDikNwTblUhdgUlSupWtYQXXkpDFSa217.dashboard -- Error: Either org permission or org preference are not enabled for flex table

I could not google this error at all and I am getting quite desperate. I would very much like to avoid having to recreate this dashboard, as we have quite a lot of sandboxes.

My user has both the Report Builder and Report Builder (Lightning Experience) permissions.

I have identified, that the culprit for this is the Lightning table dashboard component. SF is not creating the 'DashboardFlexTableComponentProperties' for it and my manual attempts to add it to the metadata was not successful.

Please help.

  • Deploying dashboards is definitely possible. What editions do you encounter this error on? Both source org and destination – blank Aug 21 '18 at 11:07
  • both are sandboxes made from production edition. – Adam Janicko Aug 30 '18 at 8:01
1

To anyone still having this issue, the FlexTable component type was introduced in API version 41, if your deployment tool is not referencing that API version or later your metadata export may not include these components, nor will it be able to deploy them correctly.

If you are using MavensMate go to Settings within the app(clicking on the gear in the upper right corner), find the section "SALESFORCE API VERSION (MM_API_VERSION)" and update the number to your desired API version (as of Winter '19 the API version is 44.0).

#DontStopDeploying

  • I'm using Force.com IDE, I already updated my package to be API version 44.0 which also matches my Target Org but I still get this error. How to solve this?? – compski Jan 14 at 6:36
0

One way to do a quick fix is to change component type from FlexTable to Table

 <dashboardComponent>
            <autoselectColumnsFromReport>false</autoselectColumnsFromReport>
            <componentType>Table</componentType>
            <header>Order Report</header>
            <report>report folder/report_Sne1</report>
 </dashboardComponent>

then after deploy change it back to FlexTable again if you need it to be a lightning table.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.