0

I have a Custom Object called MCC with two fields:

Name : 'MCC NAME'
Code__c: 1234

I have a lookup field on Lead to the MCC object. I am trying to import Leads using the Data Import wizard using a CSV with a column containing the MCC.Code__c value (i.e, 1234).

  • Using the DataLoader.io I am able to populate the Lead lookup field by looking up on the MCC.Code__c field.
  • Using the Data import wizard I can only choose to look this up using either
    MCC Name or Salesforce.com Id or --None--

I have tried this as SysAdmin, I have full access to the object and the Field, it is on the layout (default) yet the Code__c custom field does not appear as an option in the picklist. Is there a way to add the custom field to the picklist so that I can successfully insert these leads using the data import wizard?

I have done some research, found some similar questions:
(Using the import wizard how does one import lookup fields)
(Data Import Wizard doesnt show custom field of a custom object)
but there does not seem to be an answer or a workaround. (Besides using the data loader or by changing the CSV to contain the MCC Id instead of the MCC Code)

2

My advice is to recheck below noted points properly in your org and verify it.

The Data Import Wizard respects Salesforce admins’ field access as specified in page layouts and field-level security. This feature is available in both Lightning Experience and Salesforce Classic.

As per the Page Layouts and Field-Level Security documentation, page layouts determine the fields that Users can import data into. If Users are reporting fields are no longer available for mapping when using the Data Import Wizard an administrator will need to ensure that the affected Users now have appropriate access set for the missing fields. Resolution
Ensure that the affected users profile's assigned record types and their associated page layouts include the missing fields.

If the fields are contained on the page layouts, check field level security for the missing fields on the importing user's assigned profile. You can view field access by field, profile or record type via Setup, type "Field" in the quick find box and click Field Accessibility under the Security Controls menu.

To import leads via the Data Import Wizard: Import Leads permission for user needed and “Read,” “Create,” “Edit,” and “Delete” on the objects

If you can’t import field values that you’ve successfully imported in the past, check these settings. In your assigned profiles, check that your page layout assignments and field-level security settings allow you to see and edit the fields. In your assigned permission sets, check that the field permissions allow you to read and edit the fields. User permissions, such as “Edit Read Only Fields,” also affect whether you can import field values, but that behavior hasn’t changed in this release.

Reference:-

Hope it helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.